Simplex Connect - Flow-dev outage – Incident details
Report an issue
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
Dark mode
All systems operational
Flow-dev outage
Resolved
Under maintenance
Started 4 months ago
Lasted about 1 hour
Updates
Resolved
June 30, 2025 at 8:50 AM
Resolved
June 30, 2025 at 8:50 AM
This incident has been resolved.
Identified
June 30, 2025 at 8:00 AM
Identified
June 30, 2025 at 8:00 AM
We are currently done investigating this incident.